Page 1 of 1

Boolean flags naming

PostPosted: 21 Feb 2013, 21:32
by Ursego
Don't give Boolean variables and parameters "super-universal" names like flag or switchIt. Instead, write what exactly they flag/switch.

For example, if a method's argument enables or disables fields with personal information then call it enablePersonalInfo - you should describe what the argument is doing or which information it brings, you don't need to explain other programmers what Boolean type is! :lol: The only exception to this rule - if the meaning of the Boolean argument is conveyed by the method's name: for example, the method SetReadOnlyMode() can have an argument named simply switchIt (so it's understood that passing false cancels the mode).